Husky 610 SM Clutch Cable instalation problems 08 610SM
Results 1 to 7 of 7

Thread: Husky 610 SM Clutch Cable instalation problems 08 610SM

  1. #1
    Join Date
    Jul 2010
    Location
    Las Cruces, NM, USA
    Posts
    58

    Default Husky 610 SM Clutch Cable instalation problems 08 610SM

    I have a 08 610 SM and I snapped my 2nd clutch cable. While installing the new cable I noticed that the clutch did not have any rebound from the spring which is attached to it. The spring was completely unresponsive in pulling the clutch back. When I tried to tension the spring by wrapping it around the clutch one more time it pulled the clutch pin out of its wrest. Does anyone have any ideas what is going on? I can set the clutch pin back into its resting point but feel that it is not engaging the way it is supposed to. And the spring is still unresponsive. I have included a picture.
    Attached Images Attached Images
    Last edited by motocrossism; 11-26-2012 at 11:01 AM.
    Daniel
    Husqvarna SM 610
    Yamaha YZ450F

  2.  
    Advertisement
  3. #2
    Join Date
    Jul 2011
    Location
    Bozeman, MT
    Posts
    1,125

    Default

    2006 Husqvarna 610SM
    1996 XR400R - minimally street legal
    2005 CRF450R - Street tard!

  4. #3
    Join Date
    Jul 2010
    Location
    Las Cruces, NM, USA
    Posts
    58

    Default

    Thanks, let me try this again

    Daniel
    Husqvarna SM 610
    Yamaha YZ450F

  5. Remove Advertisements
    SuperMotoJunkie.com
    Advertisements
     

  6. #4
    Join Date
    Jul 2011
    Location
    Bozeman, MT
    Posts
    1,125

    Default

    this is what it should look like:

    2006 Husqvarna 610SM
    1996 XR400R - minimally street legal
    2005 CRF450R - Street tard!

  7. #5
    Join Date
    Jul 2010
    Location
    Las Cruces, NM, USA
    Posts
    58

    Default

    Yes, the problem is that the spring is not pulling the lever back. It has no tension. And when I tried to tension it by winding it around itself another time it pulled the entire lever almost out of the bike. I was able to slide the lever back into the bike but I do not believe it is wresting in its original position.
    Daniel
    Husqvarna SM 610
    Yamaha YZ450F

  8. #6
    Join Date
    Jul 2010
    Location
    Las Cruces, NM, USA
    Posts
    58

    Default

    Any ideas?
    Daniel
    Husqvarna SM 610
    Yamaha YZ450F

  9. #7
    Join Date
    Oct 2011
    Location
    Slovenia
    Posts
    45

    Default

    That clutch lever could be broken in half...there wore few members from cafehusky who reported that problem!
    Husqvarna SM 610 ´08

  10.  
    Advertisement

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •